[an error occurred while processing this directive]
Location: > Products > 4D Components > eTrans > Requirements    Site Map
[an error occurred while processing this directive]

Requirements

eTrans works on top of the HTTP Client Deux 4D component, which in turn requires the TCP Deux 4D component.

HTTP Client Deux provides a comprehensive set of HTTP and HTTPS request methods for use throughout 4D projects. HTTP Client Deux v1.1.0 or above is required to function properly with eTrans.

TCP Deux provides completely transparent operation with 4D Internet Commands v6.7.x, Internet ToolKit v2.0.x, and Internet ToolKit v2.5.x. However, because eTrans needs to communicate with the authorization service providers via SSL, it also requires ITK 2.5.x. TCP Deux v1.1.0 or above is required to function properly with eTrans.

The eTrans, HTTP Client Deux, and TCP Deux components require that the BASh component also be installed to operate properly. BASh is available for free from Deep Sky Technologies, Inc., and provides essential routines useful to all 4D programmers. BASh v1.7.0 or above is required to function properly with eTrans.

eTrans requires that you use HTTP Client Deux v1.1.0 or above, TCP Deux v1.1.0 or above and BASh v1.7.0 or above. You can get the latest copies of all required components from the downloads page.

[an error occurred while processing this directive]